Bug 13960

Summary: rtl8187 not connect to wifi
Product: Drivers Reporter: David Heidelberg (okias) (david)
Component: NetworkAssignee: Larry Finger (Larry.Finger)
Severity: high CC: htl10, Larry.Finger, linville, rjw
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.31-rc5 Subsystem:
Regression: Yes Bisected commit-id:
Bug Depends on:    
Bug Blocks: 13615    
Attachments: dmesg_from_30

Description David Heidelberg (okias) 2009-08-10 19:16:26 UTC
Created attachment 22667 [details]

Working fine with 2.6.30, not working with 2.6.31-rc5 (both - nm and manual connect). It try connect, but it fail. It's not signal problem, AP distance is about 3m.
Comment 1 David Heidelberg (okias) 2009-08-10 19:25:44 UTC
it worked once with .31, after reboot from .30, second try not worked. Adding dmesg from .31
Comment 2 David Heidelberg (okias) 2009-08-10 19:26:41 UTC
Created attachment 22668 [details]
Comment 3 John W. Linville 2009-08-11 12:29:08 UTC
[  105.777403] wlan0: direct probe to AP 00:21:63:e9:83:2b try 1
[  105.977062] wlan0: direct probe to AP 00:21:63:e9:83:2b try 2
[  106.176052] wlan0: direct probe to AP 00:21:63:e9:83:2b try 3
[  106.377239] wlan0: direct probe to AP 00:21:63:e9:83:2b timed out

Didn't we put some fixes into wireless-testing to address this type of issue?  Do we need to dig those out and redirect them to 2.6.31?
Comment 4 Johannes Berg 2009-08-11 12:32:24 UTC
Not sure why you're adding me -- its most likely just the driver not transmitting or receiving correctly.
Comment 5 John W. Linville 2009-08-11 12:40:06 UTC
Just thought you might have some insight -- didn't we just deal with this in w-t?
Comment 6 John W. Linville 2009-08-11 12:51:19 UTC
Looks like those issues were fall-out from some other changes, probably not at play here...

okias, could you do a git bisect from 2.6.30 to 2.6.31-rc5 to try to narrow-down the problem?  There are a handful of changes in drivers/net/wireless/rtl818x but none of them look immediately obvious as culprits to me.
Comment 7 Larry Finger 2009-08-20 03:32:57 UTC
It is most important for the OP to bisect the problem. On v2.6.31-rc6-223-g6c30c53, both my RTL8187 and RTL8187B work perfectly, thus I cannot confirm this problem.

What encryption is being used? Mine is using WPA2/TKIP.
Comment 8 Larry Finger 2009-08-20 15:52:58 UTC
While testing openSUSE 11.2 Milestone 5, I did see a similar problem. When I unplugged/replugged the RTL8187B, then it worked. Can you unplug your device? If so, does that make it work?
Comment 9 Larry Finger 2009-08-21 01:11:46 UTC
Created attachment 22798 [details]

This patch fixes the problem on my computer.
Comment 10 Hin-Tak Leung 2009-08-21 03:34:22 UTC
This sounds like one of the mysterious problems I reported a while ago, and also seems to be about of the same time frame - I couldn' t switch from compat-wireless to compat-wireless, but had to switch back to as-shipped modules first.
Comment 11 Rafael J. Wysocki 2009-08-21 22:00:38 UTC
Handled-By : Larry Finger <Larry.Finger@lwfinger.net>
Patch : http://bugzilla.kernel.org/attachment.cgi?id=22798