Bug 13571

Summary: ACPI: I/O resource w83627ehf [0x295-0x296] conflicts with ACPI region HWRE [0x290-0x299]
Product: ACPI Reporter: cjdcom
Component: Config-InterruptsAssignee: ykzhao (yakui.zhao)
Status: CLOSED DOCUMENTED    
Severity: normal CC: lenb, vc, yakui.zhao
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.29 & 2.6.30 Tree: Mainline
Regression: No

Description cjdcom 2009-06-18 16:05:05 UTC
I am getting this problem with 2.6.29 and 2.6.30.

I have read this post: http://bugzilla.kernel.org/show_bug.cgi?id=12376, and tried Luca's patch for 2.6.30... but it didn't help.  I made sure I did a "make clean" and a "make Mr. Proper" before I patched -- and yes, I made sure I copied over the old kernel in my /boot dir ;).  I still get the problem.

I am using a Gentoo system, current as of today.  This problem manifested with the 2.6.29 kernels and 2.6.30. 

I am using an ASUS A8V-VM (Green) motherboard.  This is not the only weirdness I have had since the 2.6.29 kernel... but that is another story, and it may be ancillary to this problem.

Thanks.


dmesg:
----------------------------------------------------------
usb-storage: device scan complete
Adding 2000084k swap on /dev/sda3.  Priority:-1 extents:1 across:2000084k
eth0: no IPv6 routers present
w83627ehf: Found W83627EHG chip at 0x290
ACPI: I/O resource w83627ehf [0x295-0x296] conflicts with ACPI region HWRE [0x290-0x299]
ACPI: Device needs an ACPI driver
IRQ 24/nvidia: IRQF_DISABLED is not guaranteed on shared IRQs
i2c-adapter i2c-1: adapter [NVIDIA i2c adapter ] registered
i2c-adapter i2c-2: adapter [NVIDIA i2c adapter ] registered
i2c-adapter i2c-3: adapter [NVIDIA i2c adapter ] registered
hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
-------------------------------------------------------------


lspci:
------------------------------------------------------------------
00:00.0 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.5 PIC: VIA Technologies, Inc. K8M890CE I/O APIC Interrupt Controller
00:00.6 Host bridge: VIA Technologies, Inc. Device 6290
00:00.7 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
00:02.0 PCI bridge: VIA Technologies, Inc. K8T890 PCI to PCI Bridge Controller
00:0f.0 IDE interface: VIA Technologies, Inc. VT8251 AHCI/SATA 4-Port Controller
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 90)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 90)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8251 PCI to ISA Bridge
00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
00:13.0 PCI bridge: VIA Technologies, Inc. VT8251 Host Bridge
00:13.1 PCI bridge: VIA Technologies, Inc. VT8251 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
02:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)
04:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller)

cat /proc/cpuinfo:
---------------------------------------------------------------
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 55
model name      : AMD Athlon(tm) 64 Processor 4000+
stepping        : 2
cpu MHz         : 2400.000
cache size      : 1024 KB
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow rep_good pni lahf_lm
bogomips        : 4802.73
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp
---------------------------------------------------------------
motherboard manual: http://dlcdnet.asus.com/pub/ASUS/mb/socket939/A8V-VM/e2421-a8v_vm.pdf
Comment 1 ykzhao 2009-06-19 00:51:09 UTC
   From the info it seems that the I/O resource 0x290-0x299 will be accessed by BIOS. If this region is still accessed by the driver again, there exists the potential issue. 
   So IMO it is appropriate that OS complains the warning message. 
   
   And after the following commit is shipped, the corresponding driver won't be loaded again when it complains the I/O resource conflicts.
   >commit 7e90560c50f754d65884e251e94c1efa2a4b5784
   >Author: Luca Tettamanti <kronos.it@gmail.com>
   >Date:   Mon Mar 30 00:01:27 2009 +0200
      >ACPI: acpi_enforce_resource=strict by default

   Thanks.
Comment 2 ykzhao 2009-06-19 00:56:50 UTC
As the warning message indicates there exists the I/O resource between ACPI and the corresponding driver, IMO this is a BIOS issue and OS does the right thing. In such case we had better not load the corresponding driver again when this happens.

    So this bug will be rejected and marked as "will not fix".
    Thanks.
Comment 3 cjdcom 2009-06-19 03:12:40 UTC
So...

If it is a bios issue, then why didn't previous kernel versions have this problem?

with kernel 2.6.27:
-------------------------------------
eth0: no IPv6 routers present
w83627ehf: Found W83627EHG chip at 0x290
i2c-adapter i2c-1: adapter [NVIDIA i2c adapter ] registered
i2c-adapter i2c-2: adapter [NVIDIA i2c adapter ] registered
i2c-adapter i2c-3: adapter [NVIDIA i2c adapter ] registered
hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
-------------------------------------

It is the same box -- no hardware changes.
Comment 4 Vladimir Prodan 2009-06-19 15:49:30 UTC
Because now acpi_enforce_resources=strict is default:

  * acpi_enforce_resources= can be set to:
  *
- *   - strict           (2)
+ *   - strict (default) (2)
  *     -> further driver trying to access the resources will not load
- *   - lax (default)    (1)
+ *   - lax              (1)
  *     -> further driver trying to access the resources will load, but you
  *     get a system message that something might go wrong...

From now on you can add acpi_enforce_resources=lax to the kernel command line to restore old behavior.
Comment 5 cjdcom 2009-06-19 17:40:19 UTC
Ah! I see.  Thank you.  This makes sense.