Bug 13554

Summary: linux-image-2.6.30-1-686, KMS enabled: black screen, no X window
Product: Drivers Reporter: Jos van Wolput (wolput)
Component: Video(DRI - non Intel)Assignee: Jesse Barnes (jbarnes)
Severity: high CC: akpm, jbarnes, rjw
Priority: P1    
Hardware: i386   
OS: Linux   
Kernel Version: 2.6.30 Subsystem:
Regression: Yes Bisected commit-id:
Bug Depends on:    
Bug Blocks: 13070    
Attachments: dmesg when booting linux-image-2.6.30-1-686
dmesg when booting linux-image-2.6.30-rc8-686
dmesg when booting linux-image-2.6.30-rc8-686

Description Jos van Wolput 2009-06-17 06:28:25 UTC
Created attachment 21954 [details]
dmesg when booting linux-image-2.6.30-1-686

Package: linux-image-2.6.30-1-686 (2.6.30-1, Debian/Sid)
System: Debian/sid, KMS enabled (module i915 modeset=1 loaded)
Processor: Intel Pentium M 1.70 GHz
Chipset: 852GM/855GM

After upgrading the kernel-image to linux-image-2.6.30-1-686 (Debian/Sid)
booting ends with a black screen,not starting X, no more key input.
This only happens when KMS is enabled by loading module i915 modeset=1
at boot time.
Loading module i915 modeset=0 boots normally.
This issue doesn't occur with linux-image-2.6.30-rc8-686 (snapshot 13741)
and previous releases from Debian kernel-archive.

Jos van Wolput
Comment 1 Jos van Wolput 2009-06-17 06:33:47 UTC
Created attachment 21955 [details]
dmesg when booting linux-image-2.6.30-rc8-686

This is dmesg after booting linux-image-2.6.30-rc8-686, which boots cleanly.
Comment 2 Jos van Wolput 2009-06-17 06:41:02 UTC
Created attachment 21957 [details]
dmesg when booting linux-image-2.6.30-rc8-686

dmesg after booting linux-image-2.6.30-rc8-686 which boots cleanly.
Comment 3 Andrew Morton 2009-06-23 21:14:04 UTC
Reassigned this regression to DRI.
Comment 4 Jesse Barnes 2009-06-23 21:20:41 UTC
Have you tried bisecting this?
Comment 5 Jos van Wolput 2009-06-25 14:16:27 UTC
(In reply to comment #4)
> Have you tried bisecting this?

No I didn't and I don't intend to do, sorry. I am using binary linux images from
Debian, don't compile the kernel myself.
I tried once more booting 2.6.30 after compiling the latest git version of xserver. This too didn't succeed. So I keep using rc8.
Comment 6 Rafael J. Wysocki 2009-07-26 22:54:07 UTC
References : http://marc.info/?l=linux-kernel&m=124686965407853&w=4
Comment 7 Rafael J. Wysocki 2009-07-26 22:54:58 UTC
Notify-Also : Jesse Barnes <jbarnes@virtuousgeek.org>
Comment 8 Jos van Wolput 2009-07-28 11:35:30 UTC
I can no longer check this bug entry, I am no more using this computer while the disk crashed.
Comment 9 Jesse Barnes 2009-08-07 17:46:46 UTC
Ok marking as unreproducible.  If you get your machine going again and still see this issue with recent kernels, please file a bug at bugs.freedesktop.org against drm/intel using the instructions at intellinuxgraphics.org/how_to_report_bug.html