Bug 11826

Summary: extreme slowness of IO stuff using 2.6.28-rc1
Product: Timers Reporter: Yves-Alexis Perez (corsac)
Component: OtherAssignee: Jeff Garzik (jgarzik)
Severity: normal CC: alex.shi, elendil, rjw, trenn
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.28-rc1 Subsystem:
Regression: Yes Bisected commit-id:
Bug Depends on:    
Bug Blocks: 11808    
Attachments: .config for 2.6.28-rc1 on T61
dmesg for 2.6.28-rc1 on T61

Description Yves-Alexis Perez 2008-10-25 04:25:57 UTC
Latest working kernel version: 2.6.27
Earliest failing kernel version: 2.6.28-rc1
Distribution: Debian
Hardware Environment: T61
Software Environment: Luks-encrypted device-mapper
Problem Description:

I have a problem with ata stuff in 2.6.28-rc1.

I first encountered the “bug with non-ncq devices master” so I patched using e013e13bf605b9e6b702adffbe2853cfc60e7806

But then, the boot is really really slow. It seems to hangs, as if it waited for the disk. I guess you could wait for ages before something happen. But when pressing a key (I tried with right alt, but I guess any key would work), the boot process continues, as if some interrupts was generated, or something like that.

I'll attach my .config in case.

Steps to reproduce:
Comment 1 Yves-Alexis Perez 2008-10-25 04:27:23 UTC
Created attachment 18434 [details]
.config for 2.6.28-rc1 on T61
Comment 2 Yves-Alexis Perez 2008-10-25 04:27:52 UTC
As a side note, the boot process until the next lockup, where I need to press alt again, etc. 
Comment 3 Yves-Alexis Perez 2008-10-25 04:44:44 UTC
And when the laptop is finally booted, it's nearly usable, when one uses the keyboard constantly. But it still blocks when some io is done without keyboard events.

But maybe it has nothing to do with ata stuff, and maybe it's a luks problem, where it needs enough interupts and entropy generation from it, but it sounds a bit weird.

I'm attaching the dmesg when booted.
Comment 4 Yves-Alexis Perez 2008-10-25 04:45:14 UTC
Created attachment 18435 [details]
dmesg for 2.6.28-rc1 on T61
Comment 5 Tejun Heo 2008-10-26 01:12:15 UTC
Looks like you're having an IRQ routing problem.  Does pci=noacpi help?  How about irqpoll?
Comment 6 Yves-Alexis Perez 2008-10-26 03:12:55 UTC
pci=noacpi doesn't help.
irqpoll seems to fix the problem.

btw, when activating the luks encrypted volume, I first get:

alg: cipher: Test 1 failed on encryption for aes-asm

Not sure if it's related,
Comment 7 Yves-Alexis Perez 2008-10-26 03:18:49 UTC
(and it fixes the problem but kind of break the trackpoint, so not really a usable workaround :) )
Comment 8 Tejun Heo 2008-10-26 03:44:05 UTC
Thomas, this one looks like an IRQ routing problem.  Any ideas?
Comment 9 Yves-Alexis Perez 2008-10-26 23:19:26 UTC
FTR, -rc2 doesn't fix the problem.
Comment 10 Rafael J. Wysocki 2008-10-30 06:00:12 UTC
*** Bug 11893 has been marked as a duplicate of this bug. ***
Comment 11 Rafael J. Wysocki 2008-10-31 14:29:59 UTC
References : http://marc.info/?l=linux-kernel&m=122521238402963&w=4
Handled-By : Arjan van de Ven <arjan@linux.intel.com>
Notify-Also : "Carlos R. Mafra" <crmafra2@gmail.com>
Notify-Also : Frans Pop <elendil@planet.nl>
Comment 12 Rafael J. Wysocki 2008-11-02 10:36:32 UTC
On Sunday, 2 of November 2008, Yves-Alexis Perez wrote:
> On dim, 2008-11-02 at 17:06 +0100, Rafael J. Wysocki wrote:
> > The following bug entry is on the current list of known regressions
> > from 2.6.27.  Please verify if it still should be listed and let me
> > know
> > (either way).
> Yes it should be :)
Comment 13 Rafael J. Wysocki 2008-11-09 11:08:07 UTC
First-Bad-Commit : dc4304f7deee29fcdf6a2b62f7146ea7f505fd42
Comment 14 Rafael J. Wysocki 2008-11-09 12:56:17 UTC
Patch : http://marc.info/?l=linux-kernel&m=122626378131380&w=4
Comment 15 Rafael J. Wysocki 2008-11-09 12:56:57 UTC
*** Bug 11987 has been marked as a duplicate of this bug. ***
Comment 17 Yves-Alexis Perez 2008-11-10 04:32:42 UTC
I've tried with -rc4 and it *seems* fixed. I'll check during next days it's ok.