Bug 11459

Summary: kernel crash after wifi connection established
Product: Drivers Reporter: Alexey Kuznetsov (axet)
Component: network-wirelessAssignee: drivers_network-wireless (drivers_network-wireless)
Status: CLOSED CODE_FIX    
Severity: normal CC: mcgrof
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: v2.6.27-rc5 Tree: Mainline
Regression: Yes
Bug Depends on: 11394    
Bug Blocks: 11167    
Attachments: kernel-2.6.27-0.290.rc5.fc10
partial crash dump
patch
kernel-2.6.26.3-17.fc9

Description Alexey Kuznetsov 2008-08-30 03:08:22 UTC
after reboot and gdm logon my machine stuck.

i tried git kernel v2.6.27-rc5.

when i switch to tty1 before connection established i can see kernel crash. that happens only on fedora config-2.6.27-0.290.rc5.fc10 and never on fedora config kernel-2.6.26.3-17.fc9
Comment 1 Alexey Kuznetsov 2008-08-30 03:09:13 UTC
Created attachment 17541 [details]
kernel-2.6.27-0.290.rc5.fc10

config only no fedora patches
Comment 2 Alexey Kuznetsov 2008-08-30 03:12:48 UTC
Created attachment 17542 [details]
partial crash dump
Comment 3 Alexey Kuznetsov 2008-08-30 03:16:32 UTC
Created attachment 17543 [details]
patch

i use small patch, without them wifi wont establish connection.
Comment 4 Alexey Kuznetsov 2008-08-30 05:00:56 UTC
Created attachment 17544 [details]
kernel-2.6.26.3-17.fc9

only fedora 9 config, no fedora patches
Comment 5 Alexey Kuznetsov 2008-08-30 14:32:27 UTC
About regression:

i play only with git kernel v2.6.27-rc5, i do not try to use 2.6.26 kernel. i tried two different configs on same source git v2.6.27-rc5 + small patch (attached above)
Comment 6 John W. Linville 2008-09-03 12:36:25 UTC
Is the patch in comment 3 the same as the patch you mention in bug 11394 comment 19 as "tried just last one and by hand solve rejection in core.* files. then
i ignore beacon.* rej files"?
Comment 7 Alexey Kuznetsov 2008-09-03 12:45:23 UTC
yes.
Comment 8 John W. Linville 2008-09-16 12:02:04 UTC
Is this issue now fixed along w/ bug 11394?
Comment 9 Alexey Kuznetsov 2008-09-17 06:52:16 UTC
Look fine. I problem back i reopen it.