Bug 11092

Summary: Tulip (Digital DS21140) has no detection under VirtualPC and Hyper-V
Product: Drivers Reporter: Franklin Piat (fpiat)
Component: NetworkAssignee: Grant Grundler (grundler)
Status: CLOSED OBSOLETE    
Severity: normal CC: alan, grundler
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.25-2 Tree: Mainline
Regression: No
Attachments: /var/log/syslog
dmesg output

Description Franklin Piat 2008-07-15 13:58:28 UTC
Latest working kernel version: 2.6.25
Earliest failing kernel version: 2.6.18 (didn't test earlier)
Distribution: Debian/Testing (pre-lenny)
Hardware Environment: 
 Microsoft  Windows Server's Hyper-V virtual machine
 emulates a Digital Equipment Corporation DECchip 21140 [FasterNet] [1011:0009]
 which is handled by the tulip driver.
Software Environment: Debian Testing (pre-lenny).
Problem Description:
 The driver doesn't reports the device's link state, therefore Gnome's 
 NetworkManager doesn't bring up the interface.

Steps to reproduce:
 Install Debian Etch or Testing inside WindowsServer (see [1]).
 Then login and notice that the interface is down.

[1] http://wiki.debian.org/WindowsServerHyperV
Comment 1 Franklin Piat 2008-07-15 14:04:05 UTC
Created attachment 16826 [details]
/var/log/syslog
Comment 2 Franklin Piat 2008-07-15 14:05:21 UTC
Created attachment 16827 [details]
dmesg output
Comment 3 Franklin Piat 2008-07-15 14:07:47 UTC
I don't know If this problem can be solved on the driver only, but it would be great if we could find a solution so Windows admins don't get mad when they try Linux ;)

I've opened a similar bug again NetworkManager :
http://bugzilla.gnome.org/show_bug.cgi?id=542916

Your help would be appreciated.

Franklin
Comment 4 Grant Grundler 2008-11-08 21:09:26 UTC
Franklin,
1) I'm now the tulip driver maintainer. Can you reassign this bug to me please?

2) It sounds like the bug is the fact that the interface is "ifconfig up" from the RC scripts but isn't getting a link. "ifdown eth0" and "ifup eth0" makes the link work. Is this correct?

thanks,
grant
Comment 5 Herwig 2008-11-19 06:18:24 UTC
Hello from Austria!
Same error here.
Microsoft Virtual Server 2005 R2, Debian 4.0-Image.
"ifconfig -a" delivers no eth0 (but dmesg does), but there is a eth1 which can not be configured, too.

lsmod | grep tulip
>>> tulip 46560 0

modprobe -v tulip
>>> (nothing)

dmesg | grep eth
>>> eth0: Digital DS21140 Tulip rev 32 at 0001ec00, ...
>>> eth1: Using EEPROM-set media 100baseTc-FDX

Your Tip 2 lead to:
ifdown eth0
>>> interface eth0 not configured
ifdown eth1
>>> interface eth1 not configured

-------------------
Maybe this error refers to the date of the image creation, it is 1.5 years old and was created from a former colleague. In the meantime there were some Windows- and VirtualServer-Updates, maybe the image is only to old and it has to be deleted und build a new Debian-Image.
But this is the job of another colleague which isn't in the office today, I'm dealing only exceptionally with this problem.

Bye, Herwig.