Bug 110371

Summary: Only 1 CPU core usable on Intel Skylake
Product: Platform Specific/Hardware Reporter: Sjoerd Furth (sjoerd)
Component: x86-64Assignee: platform_x86_64 (platform_x86_64)
Status: RESOLVED DUPLICATE    
Severity: high CC: hpa, ludovic, sander.ashwin
Priority: P1    
Hardware: Intel   
OS: Linux   
Kernel Version: 4.4-rc8 Tree: Mainline
Regression: No
Attachments: Contains dmesg and cpuinfo

Description Sjoerd Furth 2016-01-06 00:22:23 UTC
Created attachment 198811 [details]
Contains dmesg and cpuinfo

It used to work at kernel 4.2. It won't work anymore since kernel 4.3 and higher.

I have to boot with the kernel argument "nolapic" otherwise the system won't boot at all.
Comment 1 H. Peter Anvin 2016-01-06 00:25:58 UTC
Would it be possible for you to do a "git bisect" to identify the commit which breaks your hardware?
Comment 2 Sjoerd Furth 2016-01-06 16:45:11 UTC
(In reply to H. Peter Anvin from comment #1)
> Would it be possible for you to do a "git bisect" to identify the commit
> which breaks your hardware?

As far as I tested it today the results are this:
version v4.2.8 is working, but version 4.3.0 is not

I am not sure how to proceed with identifying which commit causes the problem.
Comment 3 Sjoerd Furth 2016-01-06 23:50:26 UTC
(In reply to H. Peter Anvin from comment #1)
> Would it be possible for you to do a "git bisect" to identify the commit
> which breaks your hardware?

I have found the commit which is causing trouble.
It is this one:
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?h=v4.3-rc7&id=018155365dccecd9ea9f26e1b26fb0f960c1ee32
Comment 4 Ludovic Magerand 2016-01-08 21:29:25 UTC
Try to boot with kernel option intel_idle.max_cstate=7
If you can boot, then I guess this bug is probably just a duplicate of https://bugzilla.kernel.org/show_bug.cgi?id=109081

4.3 is the kernel version that introduced the code specific to the intel Skylake architecture (and so the processor you have)
Comment 5 Sjoerd Furth 2016-01-08 22:17:51 UTC
(In reply to Ludovic Magerand from comment #4)
> Try to boot with kernel option intel_idle.max_cstate=7
> If you can boot, then I guess this bug is probably just a duplicate of
> https://bugzilla.kernel.org/show_bug.cgi?id=109081
> 
> 4.3 is the kernel version that introduced the code specific to the intel
> Skylake architecture (and so the processor you have)

Dear Ludovic Magerand,

The system did indeed boot with that kernel string. Stupid of me that I couldn't find that other bugreport.
I am going to mark this bug report as duplicate.

Thanks you!

With kind regards.

*** This bug has been marked as a duplicate of bug 109081 ***