Bug 10137

Summary: DVD record doesn't work on SATA.
Product: IO/Storage Reporter: Ilya (dik_again)
Component: Serial ATAAssignee: Tejun Heo (tj)
Status: RESOLVED DUPLICATE    
Severity: high CC: akpm, htejun
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.22.9 - 2.6.25-rc3 Tree: Mainline
Regression: ---

Description Ilya 2008-02-29 08:54:17 UTC
Latest working kernel version:
Earliest failing kernel version:
Distribution:Mandriva 2007.1
Hardware Environment:Athlon, A7V600 motherboard, VIA SATA chipset
Software Environment:growisofs latest, kernel 2.6.22.9
Problem Description:
Hi!

When I burn a *.iso image onto a DVD result fail.

The burned image equal's except first 0x20 bytes. (The size of burned DVD is 'iso_size'+0x20)

Here are 2 examples of the differences:

00000000   2A 00 00 00  00 00 00 00  1F 00 00 00  00 00 00 00  00 00 13 F6  00 00 00 10
00000018   00 00 13 F6  00 00 00 10  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00


00000000   2A 00 00 00  00 00 00 00  10 00 00 00  00 00 00 00  00 23 05 40  00 00 00 10
00000018   00 23 05 40  00 00 00 10  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00

Steps to reproduce: burn any ISO image.
Comment 1 Andrew Morton 2008-02-29 13:29:52 UTC
Pretty old kernel.  Is it reproducible with 2.6.25 or 2.6.25-rc3?
Comment 2 Ilya 2008-02-29 18:27:21 UTC
(In reply to comment #1)
> Pretty old kernel.  Is it reproducible with 2.6.25 or 2.6.25-rc3?
> 

Yes. I have downloaded the latest kernel (2.6.25-rc3)... The same thing.

The Motherboard has, AFAIK, Via VT8237 Chipset.

PS
   Burned image can be mounted in this way:
   mount -o loop,offset=32 /dev/sr0 /mountpoint.
Comment 3 Ilya 2008-02-29 18:31:42 UTC
(In reply to comment #1)
> Pretty old kernel.  Is it reproducible with 2.6.25 or 2.6.25-rc3?
> 

The bug is reproducible with latest cdrecord too (original, not wodim).
Comment 4 Ilya 2008-03-01 03:05:34 UTC
(In reply to comment #3)
> (In reply to comment #1)
> > Pretty old kernel.  Is it reproducible with 2.6.25 or 2.6.25-rc3?
> > 
> 
> The bug is reproducible with latest cdrecord too (original, not wodim).
> 

And with wodim, of course, too.
Comment 5 Ilya 2008-03-04 05:08:09 UTC
(In reply to comment #1)
> Pretty old kernel.  Is it reproducible with 2.6.25 or 2.6.25-rc3?
> 

Are you need more info?
Can I help?
Comment 6 Tejun Heo 2008-09-28 19:02:34 UTC
Let's move over to bz #11622.

*** This bug has been marked as a duplicate of bug 11622 ***