Bug 101271

Summary: HP Pavilion 11-n003ng x360 2in1 Notebook Unable turn off power
Product: Drivers Reporter: Matthias Fiedler (matthias30)
Component: OtherAssignee: Andy Shevchenko (andy.shevchenko)
Status: RESOLVED CODE_FIX    
Severity: normal CC: aaron.lu, alan.christopher.jenkins, andy.shevchenko, lexicall, marci_r, samuel-kbugs
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 4.0.6 Tree: Fedora
Regression: No
Bug Depends on:    
Bug Blocks: 85931    

Description Matthias Fiedler 2015-07-09 09:11:41 UTC
Description of problem:
Fedora 22 is unable tot urn the power off or reboot the HP Pavilion 11-n003ng x360 2in1 Notebook. You see the Text "Powerig of and it whon't do this so i muss press the powerbutten to  turn the Power off.



Version-Release number of selected component (if applicable):


How reproducible: Everytime


Steps to Reproduce:
1.Install fedora 22
2.Reboot or restart fedora 22
3.Shutdown or Reboot stuck on "Powering off" text

Actual results:
I must prees Powerbutton on netbook to turn power off

Expected results:


Additional info:

Base Board Information
Manufacturer: Hewlett-Packard
Product Name: 2209
Version: 57.37
Serial Number: PEQACC21V7UMSP
Asset Tag: Type2 - Board Asset Tag
Features:
Board is a hosting board
Board is replaceable
Location In Chassis: Type2 - Board Chassis Location
Chassis Handle: 0x0003
Type: Motherboard
Contained Object Handles: 0

Handle 0x0003, DMI type 3, 24 bytes
Chassis Information
Manufacturer: Hewlett-Packard
Type: Notebook
Lock: Not Present
Version: Chassis Version
Serial Number: Chassis Serial Number
Asset Tag: Chassis Asset Tag
Boot-up State: Safe
Power Supply State: Safe
Thermal State: Safe
Security Status: None
OEM Information: 0x0000005F
Height: Unspecified
Number Of Power Cords: 1
Contained Elements: 0
SKU Number: Not Specified

Characteristics:
PCI is supported
BIOS is upgradeable
BIOS shadowing is allowed
Boot from CD is supported
Selectable boot is supported
EDD is supported
8042 keyboard services are supported (int 9h)
Serial services are supported (int 14h)
Printer services are supported (int 17h)
CGA/mono video services are supported (int 10h)
ACPI is supported
USB legacy is supported
ATAPI Zip drive boot is supported
BIOS boot specification is supported
Function key-initiated network boot is supported
Targeted content distribution is supported
BIOS Revision: 15.21
Firmware Revision: 57.37

Handle 0x0001, DMI type 1, 27 bytes
System Information
Manufacturer: Hewlett-Packard
Product Name: HP Pavilion 11 x360 PC
Version: 0977100000405F00010420180
Serial Number: CND45288C0
UUID: EBDF1A43-F983-E411-A26A-D0BF9C58FD06
Wake-up Type: Power Switch
SKU Number: L0M41EA#ABD
Family: 103C_5335KV G=N L=CON B=HP S=PAV X=MIN

it looks like an ACPI bug in the actual kernel,

On the following url´ s you can find this problem again on fedora 21 and 222
https://bugzilla.redhat.com/show_bug.cgi?id=1184273
https://bugzilla.redhat.com/show_bug.cgi?id=1240922
Comment 1 Aaron Lu 2015-07-14 06:40:44 UTC
According to the redhat bug page, it is related to the dw_dmac kernel module. Is it still the case with the latest kernel?
Comment 2 Matthias Fiedler 2015-07-23 15:29:01 UTC
sorry i was for few weeks in a hospital and can´ t answer you.

yes, since kernel 4.0.8 it look as it work fine, but i´ ve take the update for 6 minutes and the next 2 reboot and the shutdown was okay.

i still monitor my netbook and report when the  error came back
Comment 3 Aaron Lu 2015-07-24 02:13:45 UTC
I'll move this bug to drivers/other category due to no DMA category.
Comment 6 Aaron Lu 2015-11-02 08:19:00 UTC
Any update here?
Comment 7 Andy Shevchenko 2015-12-02 10:06:50 UTC
The fix has been submitted for review: http://www.spinics.net/lists/dmaengine/msg07290.html.
Comment 8 Andy Shevchenko 2015-12-20 16:26:19 UTC
The v3 http://www.spinics.net/lists/dmaengine/msg07497.html which becomes a part of 4.5.
Comment 9 Matthias Fiedler 2015-12-21 08:51:09 UTC
a nother way to solce the Problem ist to install the kernel 4.4 rc 5. In my case the hp pavilion  11 x360 shout down correctly
Comment 10 Andy Shevchenko 2015-12-21 09:05:47 UTC
(In reply to Matthias Fiedler from comment #9)
> a nother way to solce the Problem ist to install the kernel 4.4 rc 5. In my
> case the hp pavilion  11 x360 shout down correctly

You are just lucky, or it is not about dw_dmac issue, or you have dw_dmac blacklisted.
Comment 11 Matthias Fiedler 2015-12-21 10:20:31 UTC
maybe that i am lucky.

it´ s fact that i have do a fresh install of Fedoa 23 and  not blacklisted dw_mac
Comment 12 Andy Shevchenko 2015-12-21 11:42:41 UTC
It might be different scenario when modules are load and removed in a safe way. Which is considered 'being lucky'. Also might be a case that Fedora's guys back ported mentioned series to their kernel. In any case I let this bug flying around in ASSIGNED state until someone can really confirms that it is fixed by 4.5 kernel.
Comment 13 Andy Shevchenko 2016-01-27 18:06:28 UTC
v4.5-rc1 is out. Please, re-check on it.
Comment 14 Alan Jenkins 2016-03-01 11:32:20 UTC
Hi Andy.  I have a very similar problem so I hope it's ok to contact you here.   dw_dmac hangs on my Braswell N3050 system, starting with Fedora kernel 4.4.2.  Kernel 4.3.5 was OK.

I would like to report my hang is fixed in vanilla kernel 4.5-rc5-something.  I assume this is a potentially useful endorsement for your fix :).  Thanks!

Filed at Fedora: https://bugzilla.redhat.com/show_bug.cgi?id=1313296
Comment 15 Andy Shevchenko 2016-03-01 11:38:35 UTC
(In reply to Alan Jenkins from comment #14)
> Hi Andy.  I have a very similar problem so I hope it's ok to contact you
> here.   dw_dmac hangs on my Braswell N3050 system, starting with Fedora
> kernel 4.4.2.  Kernel 4.3.5 was OK.
> 
> I would like to report my hang is fixed in vanilla kernel 4.5-rc5-something.
> I assume this is a potentially useful endorsement for your fix :).  Thanks!
> 
> Filed at Fedora: https://bugzilla.redhat.com/show_bug.cgi?id=1313296

Yes, that's useful, thank you.
Comment 16 Alan Jenkins 2016-03-01 13:30:18 UTC
Except the RC kernel then bricked my NUC.  So I would suggest any owners of Atom NUCs *not* to try run kernel 4.5-* for now.
Comment 19 Andy Shevchenko 2016-03-22 13:19:25 UTC
Confirmed fixed as per comments in bug #85931.
Comment 20 Andy Shevchenko 2016-08-10 16:31:27 UTC
*** Bug 104641 has been marked as a duplicate of this bug. ***